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Docudex is continuously being enhanced.    For details on the latest changes and available updated 
version, please contact Informatik Inc. info@informatik.com. If you require a comprehensive 
document imaging system with a customizable relational database and query system, consider the 
Docuthek System.    
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Copyright, Registration, Technical Support

This system was developed by Informatik Inc, P.O. Box 868, Devon, Pennsylvania 19333.    For 
information on program modifications, systems integrations and custom applications, please contact 
Informatik Inc.

This is a copyright-protected shareware product.    If, after review and evaluation, you like the 
software, please register.    Shareware is based on trust, and we hope that all users will register.    
Upon registration and payment of the registration fee, Informatik Inc will send you the latest master 
diskette, a registration certificate and a User Guide.    Registered users will receive technical support 
and software upgrades as specified in the application.

To register

From the About menu, choose 'Registration, Copyright, License' and follow the instructions.

To obtain technical support

From the Help menu, choose Technical Support and follow the instructions.

Infothek is a trademark of Informatik Inc.

© 1994-1995 Informatik Inc
All rights reserved



Add (Post) a New    Record

 See also Edit a Record 

Before you index an image,    make sure that the image has been committed to the permanent 
archive (normally an optical disk). The commitment of the image to the permanent archive and the 
indexing is normally done at the same time.    Please read    Image - Indexing.

To add a record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. From the Edit menu in the Data Edit and Indexing window, choose Clear Screen, or click the 
Clear button (cross-out).    Generally, this step is not required if all fields are already blank.    
Clearing the screen creates a blank record, ready to be filled in.

2. Enter the data. You can copy the text of the previous entry by clicking on the C button next to the
edit field.    Type only one key in each keyword fields.    A key may be a single word or a group of 
words.    The entry is NOT case sensitive.    Do not enter wildcard characters.    The date field 
accepts most common date formats and the date format need not be consistent. Only the 
Description field requires mandatory input; all other fields are optional.    For practical purposes, 
however, you should enter at least one keyword.    The Drawer and Folder fields are useful for 
classifying and grouping the records.    Press the 'B' button to view a pick-list of existing drawers 
and folders.    The Date fields is important if you want to search document images by date or date
ranges.

3. To clone a record, choose Clone from the Edit menu, make any necessary changes to the new 
record and confirm, as explained above. 

5. Special characters can be entered from the Edit | ASCII Characters menu.

6. Press the Update button, or choose Update Record from the File menu.    The screen is cleared 
and the system is ready for the next record.

.



Search a Record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. Click the field that you want to search.    

2. Choose the Search menu.    

3. In the dialog box, specify the search characters..    

4. Press the Search button.    

The system displays the first matching record.    If there are several matching records, use the 
'Arrows' button to move to the next or prior record.

The search feature filters out the records with matching word patterns.    Only the matched records 
are included in the lineup of records.    To remove the filter, blank out the search box (or enter an 
asterisk) and click the Search button again.



Edit (Change) a Record, Delete a Record

See also: Add a New Record

To edit an existing record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. In the Data Edit and Indexing window, select the record that you want to edit.    Use the arrow 
buttons, choose a navigation option from the File menu, or perform a search.    See also Search 
Record.

2. Make the changes to    the record.

3. For special characters, choose ASCII Characters from the Edit menu.

4. To 'undo' the changes and to restore the current record, choose Restore from the File menu.

5. Press    the Update button (check mark) or choose Update Record from the File menu, or move    
to another record.    Moving to another record automatically updates the changes.

6. To delete a record, choose Delete Record from the File menu.    Confirm.



Image - Renumber Pages, Delete Pages

TIFF and DCX file formats support multiple pages.    When appending an image to an existing file, 
the image is always appended as the last page.    However, the pages can be re-numbered or 
deleted in a separate procedure.

To re-arrange or delete a page

1. Open the document image.    The first page of the image is displayed.

2. From the File menu, choose Renumber/Delete Pages.    The Renumber/Delete Pages window 
appears.

3. In the second column of the grid of page numbers, click the page that you want to move or 
delete. 

4. Choose the Up, Down or Delete button.    To move the page several steps, repeat the process for
each step.

5. To start over, choose the Refresh button.

6. To execute the move or delete, choose OK.

7. If a page is deleted, the original file is temporarily saved in the SAVEIMG file in the application's 
directory.



Save Image

The image is normally saved as part of the indexing process.    It can also be saved from the File 
menu of the imaging window.

1. In the Image window, display the image.

2. From the File menu, choose Save As.    The Save AS form is displayed.

3. Select the directory.

4. In the Graphics Format list, select the format code (normally TIF).

5. In the File Name box, type the file name.    If the file name has a trailing serial number, you can 
increment the number by pressing the Next Serial Number button.

6. Choose Save.

If the file name already exists, files in the TIFF and DC formats are appended as new pages . 

 



Database Query (Search)

1. Click on the Query button (question marks) in the toolbar, or choose Query from the File menu.    
The Search Form is displayed.

2. Specify the search criteria.    The more parameters you enter, the more narrow the search will be.
Search parameters for drawer, folder and date must be entered in their respective fields.    The 
keywords can be entered in any order in any of the keyword fields.

3. To delimit the search for records for certain dates, use the Date Delimiter field, and specify the 
mode (before, after, exactly or between).    The 'before' and 'after' options include the beginning    
or ending date.    If you use the between option, you must enter the 'from' and 'to' date with the 
keyword 'to' placed between, for example 12/1/95 to 12/31/95.      The date field accepts most 
commonly used formats, such as Jan 15,1995 or 1/15/95.    If you omit the year, the system uses 
the current year.

4. The system uses trailing wildcard characters, unless suppressed.    With that method, for 
example, if you search for the keyword STAR, the system will locate all keywords that start with 
STAR and the hits will include such words as STARTREK, START, STARS, STARTING, etc.    To 
suppress the wildcard option, remove the checkmark in the Wildcard checkbox.

5. If you specify several parameters, the system uses the 'AND' Boolean function, unless specified 
otherwise.    To specify a Boolean 'OR' in the keyword fields, click on the 'Or' checkbox.

6. To execute the search, click on the Search button in the toolbar (greed dot), press F8 or choose 
Run Search from the File menu.

7. The system displays all matched records.    To view the detail of the record, press the left mouse 
button, press F9, or choose Show Detail from the File menu.

8. To view the image, select the item on the list and click on the Image button in the toolbar 
(camera), or press F12, or choose Display image from the File menu.



Image - View, Print

Images can be opened via the Search window or, if you know the image file name, directly from the 
Imaging window. 

The images are always displayed in the currently active image window.    If you want to display 
the image in a new and separate window, select New from the File menu in the Image window 
BEFORE you select the new image.    

To display an image

1. In the Search window, run a search.    The search will identify and list all matching image files.    
(To open an image without a search, choose Open from the File menu in the Image window or 
click the Open Image button in the toolbar.    In the dialog box, select the directory and specify 
the file name.    Ignore paragraph 2 below.)

2. From the list of matching records, select the image that you want to display and press the 
Imaging button in the toolbar (camera), or choose Display Image from the File menu,    or press 
F12.      The Imaging    window opens and the image is displayed.

3. If necessary, change the viewing aspects.    From the View menu, choose:

Resize Image
Fit to Window (retaining the proportional aspects)
Zoom (see below)
Copy
Rotate 
First, next, prior, last page (applicable only to certain graphics formats)

4. Open the next or prior image, as follows:

Open - Next File Displays the next serialized file.
Open - Prior File Displays the prior serialized file.
Open - Next Query Displays the image in the SQL Query Report.
Open - Prior Query Displays the image in the SQL Query Report.

To print the image
1. Select and display the image as explained above.

2. From the File menu, choose Print.    The Print Image window appears.

3. Specify the Scale Options.    Select 'Scale to Fit' or choose a specific scale.

4. Specify the top and left margins (offset), or select 'Centered'.    The values must be entered in 
inches, e.g. 1.125.

5. If the document consists of several pages, specify the 'from' and 'to' page numbers. Pages are 
supported only for TIF and DCX file formats.



6. To set up the printer, choose Setup Printer.    This step is normally not required.

7. Choose OK.

Set the Window Size

The window size can be set for the duration of the session by choosing Set Windows Size from the 
View menu.

Zoom

From the View menu, choose Zoom.    The mouse pointer changes to a cross-hair.      Select a 
section of the image with your mouse.    Drag the mouse while holding down the left button.    The 
selected area is indicated by a 'rubber band'.    Release the mouse.    The zoomed section is 
displayed.    The zoom field can be dragged to another location.    To cancel the zoom field, click on 
the main image or press the Delete key.    AutoZoom (F6) zooms in on the image section previously 
selected.

Copy

To copy a section of the image, choose Copy from the Edit menu.    The mouse pointer changes to a 
cross-hair.      Select a section of the image with your mouse.    Drag the mouse while holding down 
the left button.    The selected area is indicated by a 'rubber band'.    Release the mouse.    The 
selected area is copied to the Windows Clipboard.

Close the Image

An image window may be closed by double-clicking the Control button in the upper-left corner of the 
image window, by choosing Close from the File menu, or by pressing the Delete key.



Image - Indexing

See also:    Add (Post) a New Record 

The indexing of an image consists of two separate actions: 1) You must copy the scanned image to 
a permanent disk file (archive), such as an optical disk, and, 2) you must create an index so that the 
image can be located quickly. 

To index an image

If the image does not need to be reformatted (e.g. to TIFF), and if you do not need to relocate 
the image file to another directory, then ignore sections 1 - 5 below and go straight to section 
6.

1. If not already displayed on the screen, open the image file.    From the File menu, choose Open 
and specify the file name.

2. Form the Menu menu, choose Data Edit and Indexing, or click the Edit button (pencil).    

3. For the first image in a session, specify the directory of the permanent image files (archive).    In   
frame at the top of the window, click the Directory field.    The Document Directory window is 
displayed.    From the various pull-down lists, select the drive and directory and specify the 
Graphics Format (normally TIFF).    Choose OK.

4. In the Data Edit and Indexing window, in the frame at the top, enter the new file name.    The file 
name must conform to the MS DOS file naming convention (maximum eight characters).    Do 
NOT enter an extension name.    To copy the current image file name, simply click on the Dub 
button.

If the destination file name has trailing numerals, for example IMAGE001, the file name can be 
incremented to the next serial number by simply pressing the Increment button.

If you want the system to delete the source image file automatically, after the image is committed
to the permanent file, check the Auto-Delete box.

If the system should default the image file name of the permanent file to the source file name 
(except the extension name), check the Auto-Dub box.

5.  For a new image file, press the Commit New button; to append the image to an existing file 
(TIFF and DCX files only), press the Commit Append button .    The image is now copied to the 
new file.

6. Enter all the fields.    The file name is already defaulted.    See also:    Add (Post) a New Record 

7. Press the Confirm button (checkmark).

8. Display the next image.    From the File menu of the image system (not Data    Edit and Indexing),
choose Open File or Open Next File.    Power users press F5 to quickly retrieve the next file.    
(Open Next File works only if the file name has numeric suffixes). 



Shortcut

Press F3 to repeat the field entry from the prior confirmed record.    
Create a 'template' of entries (see Edit menu) and post the template by pressing Ctrl+F3. 

As a shortcut, Ctrl + F12 commits the image and confirms the index in one step.    Shift+Ctrl+F12 
commits the image, confirms the index and moves to the next image in one step.

Setup

The destination directory, the graphics format and the Auto-Dub checkbox can be defaulted on 
logon.    To default any of these fields, create a DEFAULTS.TXT file in the application's directory.    On
the first line, specify the directory; on the second line specify the graphics format (zero-based 
numeric value.    0 = TIFF, 1 = BMP, etc); on the third line enter 1 for auto-dub.    If you require only a 
partial defaulting, leave the non-defaulted lines blank.



Tutorial

You don't need a scanner to run this tutorial, but you need a few graphics files.    These graphics files
can be in one of several formats, bmp, gif, wmf, tif, etc.    If you have a scanner, you can scan some 
documents and make the tutorial more realistic.    If you scan documents, use the scanners 
autonumbering feature (if it has such a feature).    The file format and the resolution of the scanning 
do not matter. If you don't know where to find the graphics files on your system, simply run a search 
from the Windows File Manager, searching for *.bmp starting from the C:\directory.    

This tutorial uses the toolbar for navigation.      The commands also have menu options and most 
commands have key shortcuts.    You can explore the alternatives at your own leisure and adapt the 
methods best suited to suit your special requirements.

It is suggested that you print out this tutorial and follow it step by step.

1. Start the Infothek Docudex system.    From the toolbar of the opening screen, click on the 
Imaging button (camera).    A blank imaging window appears.

2. From the File menu, choose Open Image File.    In the Open dialog box, specify the directory and
the file of your first image.    Click on OK.    The image is displayed.

3. Now, we want to commit the image to the permanent archive and we need to index the image, 
i.e. give it keywords, for later database searches.    On the toolbar, click on the Edit button 
(pencil).    The Database Edit and Indexing window appears.    Click on the Database Edit window
to activate it and to refresh it.

4. Before we do the indexing, we will commit the image to a permanent archive.    If your image file 
is already compressed and located in a permanent archive, go directly to section 8.    The image 
files can also be reformatted and archived globally (see Global File Formatting).    The permanent
archive is normally an optical disk, but it can be any disk.    The permanent file may have the 
same name as the original file, or it may be given a different name.    At the top of the Database 
Edit screen, click on the Directory box.    In the Document Directory dialog, specify the drive and 
the directory for the permanent image file.    Also, specify the graphics format.    For this tutorial 
we shall choose Tiff (the default).    Press on OK.    This information will be kept for the entire 
editing session.    You only need to specify the directory and graphics format once for each 
session.

5. At the top of the Database Edit screen, click on Dub.    This will copy the current file name into 
the File Name field.    If you want to rename the file for the permanent file, you can type in the file 
name.    The file name must not exceed eight characters and it must not include the extension 
name.    To automatically copy the file name throughout the session, you should click the 
AutoDub checkbox.    If your file name is 'serialized'. i.e. if it has trailing numbers (e.g. IMG0001), 
you can use the Increment button to increase the file name by one numeric unit.    If you want the
system to automatically delete the original file once the file is committed to the permanent 
archive, check the AutoDelete box.

6. We are now ready to commit the image file to the permanent archive.    Click on the Commit New
button.    When committing subsequent images, you may choose Commit Append if you want to 
append an image as a page to an existing file.    Only tiff and dcx files support multiple pages.

7. The image file is now copied to the permanent archive and the Database Edit screen is updated. 



Notice that the last field now shows the new file name with path and extension name.    

8. Now is the time to specify the keywords for the image file.    In the Description field, type a short 
description that identifies the image.    For the tutorial we will leave the drawer and the folder 
fields blank.    These fields are intended to classify the files into groups and subject groups.    In 
one or several keyword fields, type a keyword that identifies the image.    There are five keyword 
fields; use as many as you need to index the image.    We will leave the Date Delimiter field 
blank.    If you enter a date, you would be able to search for documents by date, or date ranges.   
In the toolbar of the Database Edit window, click on the Confirm button (checkmark).    The entry 
is posted.

9. On the main toolbar click on the Open New Image button and open the next image.    
(Alternatively, activate the Image window and select the image file from the File | Open Image 
File menu.)    If you image files are serialized, i.e. if they have trailing numbers (e.g. IMG0001), 
you can press the Next Image File from the toolbar, or use the equivalent option from the File 
menu.    You should use serialized file names; they can reduce the indexing task substantially.

10. Click on the Edit button (pencil) and activate the Database Edit screen.    By activating the 
screen, the fields are refreshed to reflect the new image.    Commit the image to the permanent 
archive as explained above and post the keywords.    

11. Post several other documents so that we can perform a meaningful search.

12. Now, let us perform a search.    From the main toolbar, select the Query button (question marks). 
The Search Form is displayed.    In one (or several) keyword field(s) enter a keyword that you 
want to search.    Click on the Search button (green dot).    All the matched records are displayed 
in the table below.

13. Select one of the records in the table (click on it).    Press the RIGHT mouse button and you will 
see the complete entry for the record.

14. To see the image, simply doubleclick on the record, or press Function Key 12, or click on the 
Imaging button at the top of the Edit window (camera).

15. If there are several matches, you can view all the images in sequence by clicking on the Open 
Next Query Image button (magnifying glass with red arrow) in the toolbar.    If the image consists 
of several pages, use one of the page arrow buttons in the toolbar.

16. To print an image, choose Print from the File menu.    Set the scale and offset options and click 
on OK.



Introduction

Infothek Docudex is a simplified version of the Infothek Docuthek system.    (The Docuthek system 
includes a complete customizable relational database for indexing and a extensive SQL-based query
system.)    The Docudex system includes a fixed database with a fixed number of fields:    description,
drawer, folder, 5 keywords, and date.    What you lose in flexibility, you gain in simplicity.    

You scan the documents with any commercial scanner or with a fax machine.    If your scanner has 
the auto-numbering feature, you are advised to use that feature, but it is not required.    The format 
and the resolution of the scan do not matter.    When you index the image and commit the file to a 
permanent archive, Docudex will reformat and compress the file (assuming you use the Tiff format). 

For a quick overview of Docudex, please run thru the tutorial. 

If you have any questions, please contact us.    For support information, please read Technical 
Support in the Help menu.



Global File Formatting

Often, the image scanner creases basic uncompressed bitmap files of the image.    The files must 
then be reformatted to a compressed TIFF file and saved in a permanent archive.    Docudex 
includes a function that reformats single files, selected files or complete directories.

1. From the File menu of imaging window, choose Global File Reformatting.    The Global File 
Reformatting window appears.

2. Double-click on the directory that holds the source files.    To screen out specific file formats, 
specify the Graphics Format.

3. Highlight the files that you want to convert.    To select a single file, simply click on the file name. 
To select several files, click on each file while holding down the Ctrl key.    To select a range, click
on the first file and , while holding down the Shift key, click on the last file.

4. Specify the destination directory (double-click).

5. Specify the new graphics format.

6. the TIFF and DCX formats support multiple pages.    Check the Append box if you want to 
append the files as a new page if the file already exists.

7. If you want to be alerted if a file already exists, check the Alert box.

8. If you want the system to automatically delete the source file after creating the destination file, 
check the Automatic Delete box.

9. Click on OK.




